
 

 

  
Abstract—The use of lecture video and animation has been 

increased especially for online and distance learning courses. There 
are two major problem when an online or a multipoint course is 
offered for the first time. First, producing lecture video and animation 
is not an easy task for instructors who are going to teach online 
course first time. Second, most instructors who are novice for 
producing such teaching modules rely on pre-existing learning 
resources. In many cases those pre-existing teaching resources are not 
matching with an individual instructor’s course level or pedagogy. 
This article shows detailed ‘how-to’ tutorials for mathematics 
instructors who is novice to produce (1) animation GIFs using 
GeoGebra, (2) PDFs with embedded animations, and (3) PDFs with 
embedded ‘paper-pencil’ style lecture videos with voice using 
smartpen as instructional tools. 
 

Keywords—Animation in pdf, GeoGebra, LaTex, IrfanView, 
ShareLaTex, smartpen note  

I. INTRODUCTION 
ANY researches have been done on using animation and 
lecture videos in teaching. For instance, Milovanovic, 

et.al. A research [13] shows students learned with multimedia 
showed better theoretical, practical and visual knowledge, and 
they were highly interested in learning with multimedia. 
Another research [23] shows that students learn better with 
animations since the animation engages them in learning. 
Akpinar ([1]) found that the interactive animations used as 
presentation tools were more effective on the students’ 
understanding of course concepts. Aksoy ([2]) also found the 
similar result that animation is more effective than traditional 
teaching methods in terms of enhancing students’ achievement. 
In some researches like [10] they found that animation does 
not improve understanding across all conditions, but students 
show evidence of higher levels of understanding. 

Even though Evans ([6]) found that lecture videos might not 
be the best tool of instruction for ‘introductory’ students, a 
research ([7]) shows that usage patterns affect students’ 
attitudes to video lectures as a learning tool. Halupa ([9]) also 
found that even the students who were given access to online 
video lectures perceived course material more positively and 
felt the additional material was useful, there were no 
significant differences between students in the target group and 
the control group. On the other hand, some researchers found 
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that lecture videos will have similar or greater use and value in 
an online course when live-instruction and discussion are 
limited ([3]), and students showed improvement after watch 
visualizations (graphic design, video, and animation) and there 
was significant improvement in responses between the first and 
second visualization ([21]). 

It is clear that including animations and videos in lecture 
would be beneficial to students’ learning, and providing 
teaching modules with visualization and animation of better 
quality are demanded more than ever. Instructors are urged to 
provide visualized teaching modules for their students. The 
demand of having the ability to produce such modules 
according to own pedagogy has increased dramatically in 
teaching field. One major problem is that most instructors are 
novice to production of such materials. As stated in a recent 
study [8] instructors depend on their universities to provide the 
video capture infrastructure, and should work with the campus 
information technology personnel to produce lecture videos.  

There are some ways to produce such materials with 
minimal knowledge of media production. In this article, we 
focus on producing animation GIFs, and embedding such 
animations and lecture videos into PDF file which is one of 
best formats for teaching module since it is easy to share and 
can be viewable in any computer with a PDF reader such as 
Acrobat Reader. It is known that embedding an animation in a 
pdf file is impossible without using some high-end commercial 
programs. However, there is a way to produce PDF with 
animation (GIF) using LaTex. Some sites such as [30] provide 
source file (Tex) with the output file (pdf) for creating some 
animations in pdf/beamer. 

Holecek ([11]) describes a new way of creating animations 
in PDF with a free software pdfTeX only, which requires some 
skills of Acrobat JavaScript and pdfTeX. It is not easy for a 
novice instructor. 

A post in GeoGebratube shows how to include animated 
GIF in LaTeX and produce PDF file with animation (see [25]). 
The post explains the method to animated construction step 
with LaTex syntax and packages such as Pstrics and 
PGF/TiKZ which are not popular to most LaTex novices.  

Another site [28] shows how to include animation in pdf 
using LaTeX, especially using movie15 or Media9 packages in 
LaTex. It also shows some tools (without detail how-to) to 
create graphic files (such as MPEG) mostly for Mac OS 
system. 

In this article, we demonstrate how produce animated GIF 
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file using GeoGebra, and then how LaTex together with a free 
photo editing program such as IrfanView can be used in 
producing animation embedded in PDF file. We also introduce 
the desktop software of a smartpen and shows how to convert 
the note writing file to PDF file with video and audio 
recording together.  

II. MAKING GIF WITH GEOGEBRA 
The GeoGebra (GGb) program is the key to produce 

dynamic graphs for teaching. It makes possible to make an 
animation and/or a series of graphics quickly and effortlessly.  

A. Using a slider 
The GeoGebra program makes possible to insert sliders that 

control dynamic moves within the graphics. For producing 
animation (especially within a pdf file) from a GGb file, we 
should include at least one slider in the GGb file. For example, 
make a line segment using two points, say H and K, after 
making a slider, say t, with the following condition: Min: 0, 
Max: 1, Increment: 0.05, Animation Speed: 1, Repeat: 
Oscillating (see Fig. 1). Then type the following in the input 
filed on the GGb file: 

A = (1-t)*H + t*K 
in order to make the point A on the line segment. The position 
of the point A depends on the slider value t. We may hide the 
slider by either (1) right click on the slider and unselect Show 
Object or (2) place it outside of the animation area, if we do 
not want to show it inside the animation. 
 

  
Fig. 1 Setting for a slider in GGb 

Then, by the following steps, we will get an animated gif file: 
i. Select File > Export > Graphics View as Animated GIF 

ii. Select one slider (if there are more than one...), say t 
iii. Click Export button (see Fig. 2) 

 

 
Fig. 2 Exporting a GIF file from GGb 

To check the animation, open the gif file with a web 
browser or with IrFanView program.   

B. Using Construction Step with a Slider 
One of the excellent features of GGb program is that it 

comes with the built-in function named ‘Construction Step’. In 
many cases we want to show the entire procedure of the 
construction of the graphic, not only because instructors want 
to show the step-by-step construction but also they need to 

show the same explanation in several different classes most 
cases. Using the build-in ‘Navigation bar’ in GGb program we 
can show the entire construction steps either step-by-step or on 
play mode. As we saw in A above, we have to use a slider for 
producing animated gif file from GGb. So we need to connect 
the construction steps and a slider. If we want to show all 
construction steps, we just to assign a slider to the construction 
step number. But, in most cases, we want to show specific 
construction steps only. In such case the connection between a 
slider and the construction steps should be modifiable, so the 
animation shows selected construction steps only. Moreover, 
we do not want to change or update the setting between the 
slider and the construction steps when we change some 
construction steps and remove/add some objects. 

Inside ‘Construction Protocol’ window within GGb program 
we can rearrange the construction steps if necessary, and 
assign breakpoints for chosen steps only. So we need assign 
those breakpoint steps to a slider. We will use a construction 
of the centroid of a triangle to explain this. Let’s make a GGb 
file, titled ‘triangle.ggb’, showing the construction of the 
centroid, named G, of a triangle ABC by finding the 
intersection of three mediums AD, BE and CF, which requires 
several line segments to show that points D, E and F are the 
midpoints of the sides a, b and c. The Figure 3 shows the result 
triangle and the corresponding construction steps with 
breakpoints at steps 4, 8, 12, 16 and 17. 
 
             
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

Fig. 3 Construction Protocol Window with the figure 
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C. Procedure to Connect Construction Step and Slider 
i. Decide and check 'breakpoints' in the 'Construction 

Protocol' window (e.g. 4,8,12,16,17 – 5 breakpoints) 
ii. Make a list as the following where objects are the one 

for breakpoints: 
mylist={ConstructionStep[b], ConstructionStep[f],  

               ConstructionStep[i], ConstructionStep[l], 
              ConstructionStep[G]} 

iii. (Select Construction Protocol window > Options > 
Show Only Breakpoints) 

iv. Make a slider, named ‘myslider’ (e.g.), with: 
Min: 0, Max: 5, Increment: 1, and Repeat: Increasing 

v. (Select GGb window > Algebra > Sort Objects By ... > 
Construction Order) 

vi. Put the code below in 'Advanced > Condition to Show 
Object' of all the object which needs to be shown for the 
construction:  

ConstructionStep[nameoftheObject]<= 
Element[mylist,myslider] 

vii. Add the following code after the code in step vi above 
in 'Condition to Show Object' of the object which needs 
to be hidden after certain 'breakpoint' step, say q:   

&& cs<=q 
viii. Select File > Export > Graphics View as Animated GIF 

ix. Select the slider myslider 
x. Click 'Export' button 

# Step iii. and v. above are not necessary, but will be helpful. 

III. MAKING PNG FRAMES WITH IRFANVIEW 
To include animation into pdf file, the animation file (GIF) 

needs to convert to a series of png frames. One of the best free 
programs to make such png frames from an animated gif file is 
IrfanView (see [26]). As an example, we can use the gif file 
from internet sites (such as [27]), or our own gif file using 
some programs such as GeoGebra. To retrieve the gif file from 
an internet site, right click on the first animation and select 
`Save image as...' After save the file, we may use IrfanView to 
watch the animation of the original gif file. 

 

 

Fig. 4 A GIF in IrfanView 
 

To make the series of png frames from the animated gif file 
(`triangle') follow the steps below: 

i. Make a folder, say 'fig'. 
ii. Open the gif file with IrfanView. (See Fig. 4) 
iii. Select ‘Options > Extract all frames...’ 
iv. Change the `Destination directory:' to the `fig' folder. 
v. Select PNG-Portable Network Graphics for `Save As'. 
vi. Click `Start'. 
The procedure above produces several `frame' files with the 

same name. For instance, there may be 17 png frames in the 
`fig' folder, starting from `triangle_frame_0001' to 
`triangle_frame_0017'. The number of frames depends on the 
condition of the original gif file, especially the minimum and 
maximum frame numbers and the increment. The name of 
those frame files will be the same as the original gif file name 
with the extra ending part, such as `_frame_xxxx'. 

IV. MAKING PDF WITH ANIMATION USING SHARELATEX SITE 
To make a pdf file with animation on it we need to create a 

source (LaTex) file, and add the ‘animate’ package into the 
preamble of the source file. Before installing a Tex program 
and an Tex editor program which requires a lot of time and 
effort, we recommend using an online LaTex editor service 
site such as ShareLaTex® (see [29]). It comes with a complete 
ready to work LaTex environment running on their server with 
many LaTex source templates. It requires no pre-installation 
on user's computer, but the user needs to make an account on 
the server to use the service.  

A. Making a project in ShareLaTex site 
To make a LaTex source file in ShareLaTex site, follow the 

procedure below:  
i. Go to https://www.sharelatex.com/project, make an 

account, and then log in. 
ii. Click 'New Project' at the top left side, and select ‘Blank 

Project’. 
iii. Type a name, say ‘mytex’, for the ‘New Project’, and 

then click ‘create’. 
There will be 3 views in the ShareLaTex page: menu, source 
view and preview. (See Fig. 5) 

B. Uploading PNG frame files to the ShareLaTex project site 
The fig frame files should be uploaded to the ‘mytex’ 

project in the ShareLaTex page as the following: 
iv. Click 'New Folder' (the second icon) above the menu 

side, type a name (say ‘fig’), then click ‘Create’. 
v. Click the ‘fig’ folder in the menu. 
vi. Click 'Upload' (the third icon) above the menu side. The 

'Upload File(s)' window will be appeared. 
vii. Drag some (up to 40) png frame files from the ‘fig’ 

folder, and drop on the ‘Upload File(s)’ window. 
viii. Click the ‘fig’ folder in the menu again, and do the 

same ‘Drag-Drop’ procedure until to finish uploading the 
entire png frame files. 

The ShareLaTex site accepts up to 40 files at the same time 
for uploading. Hence the step (vii) should be done several 
times depending on the total number of frames. 
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Fig. 5 ShareLaTex Page 
 

C. Making the PDF with animation 
Replace the entire content in the source view by the 

following code: 
 
\begin{verbatim} 
\documentclass[10pt]{article} 
\usepackage{animate}  
\begin{document} 
\animategraphics[autoplay,controls] 
{12}{fig/triangle_frame_00}{01}{17} 
\end{document} 
\end{verbatim} 
 
The last number, 17, in the code above should match with 

the png frame numbers in the 'fig' folder. The folder name, fig, 
should match with the folder name in the menu. To produce 
the pdf file, do the following procedure: 

ix. Click 'main.tex' on the menu, and then click 'Recompile' 
above the preview. 

x. Click 'download PDF' icon above the preview window, 
and then open the downloaded pdf file. 

The preview window in ShareLaTex does not show the 
animation. To see the animation the pdf file should be 
downloaded from ShareLaTex site and open it with a PDF 
viewer program such as Adobe Acrobat.  

For the case of the number of frames is less than 10, say 8 
frames only, the code may be written by either 

 
\begin{verbatim} 
\animategraphics[autoplay,controls] 
{12}{fig/triangle_frame_00}{01}{08} 
\end{verbatim} 

or 
\begin{verbatim} 
\animategraphics[autoplay,controls] 
{12}{fig/triangle_frame_000}{1}{8} 
\end{verbatim} 

 
On the other hand, if the number of frames is more than 99, 

say 153 frames, then the code should be changed as: 
 
\begin{verbatim} 
\animategraphics[autoplay,controls] 
{12}{fig/triangle_frame_0}{001}{008} 
\end{verbatim} 
 
The ShareLaTex provides lots of templates such as CV, 

cover letter, presentation, thesis, etc., and they can be chosen 
after click the ‘New Project’ at the main page of ShareLaTex. 
(See Fig. 6)  

By using the code \usepackage{animate} at the preamble 
(before \begin{document}), the animation can be embedded to 
any of templates.  

 

 

Fig. 6 Templates in ShareLaTex 

D. Options 
We can assign several options (inside the blankets) 

regarding the animation using the blankets in the code. For 
instance, controls in the option in the code is for insertion of 
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control buttons below the animation. To change the size of the 
control buttons, put buttonsize=<size> in the option such as 

 
\begin{verbatim} 
[autoplay, controls, buttonsize=10pt] 
\end{verbatim} 
 
By default, the control button comes with black. By using 

buttonbg=<color> and buttonfg=<color> the control button 
colors can be changed. By default, control button widgets are 
drawn with black strokes on transparent background. The 
background can be turned into a solid color by the rst option 
such as buttonbg=rst, while the second option species the 
stroke color. The parameter is an array of colon-(:)-separated 
numbers in the range from 0.0 to 1.0. The number of array 
elements determines the color model in which the color is 
defined: (1) gray value, (3) RGB, (4) CMYK. For example, 
‘1’, ‘1:0.5:0.2’ and ‘0.5:0.3:0.7:0.1’ are valid color 
specifications such as 

 
\begin{verbatim} 
Buttonfg=1:0.5:0.2 
\end{verbatim} 
 
To make the animation loops, put loop in the option such as 
 
\begin{verbatim} 
[loop, autoplay, controls] 
\end{verbatim} 
 
To scale the size of the animation, use scale=<factor> in 

the option where <factor> is between 0 and 1, such as 
 
\begin{verbatim} 
[autoplay, scale=0.5, controls] 
\end{verbatim} 
 
Most of this section is from [24], and check out the file for 

more detail information. 

V. MAKING PDF INCLUDING LECTURE VIDEO WITH VOICE 
USING A SMARTPEN 

For more than a couple of decades many researches on 
‘designing’ a virtual classroom have been done (e.g., [20]). 
Most of them are targeting on-campus students, and so there is 
no clear concept about ‘virtual’ classroom and lecture modules 
for online courses. Sodha ([18]) claims that the reason for low-
impact of lecture notes with web-based textual information and 
static diagrams on students’ learning is the complex human 
learning process, which demands interaction between a student 
and the instructor.  

Reins ([15]) shows that digital ink technology (such as 
tablet PCs) is changing the way of students’ note taking and 
instructors’ teaching methods. Reins mentioned a recent study 
[19] showed that the tablet classroom environment is more 

effective than the traditional format of lectures. We found that 
smart pens provide a similar environment. 

The smart pen (especially Livescribe SmartPen) is designed 
to help students’ notetaking and lecture review. It comes with 
an internal microphone, a camera and a memory card for 
saving audio recording and handwriting capture for later 
review. Many researches have been done on the relation and 
effectiveness between the use of the smart pen and the 
students’ academic achievements. Sarah, Emily and Christine 
([31]) showed that the smart pen helps students with learning 
disabilities, especially for math classes by offering the ability 
to look at a problem and hear the teacher’s explanation again 
including a helpful calculator feature.  

The Livescribe Smartpen can be used to produce pdf file 
with embedded lecture videos. The Livescribe Echo smartpen 
digital voice recorder is a ballpoint pen and comes with a 
camera (at the tip of the pen) and a voice recorder together. 
Writing on a digital paper which can be made using a laser 
printer (600dpi), it records what it writes with synchronized 
audio which has recorded at the same time. Users can 
download and install the free smartpen desktop software. The 
digital copy of notes with video and audio recordings 
produced by this pen can be replayed and shared through the 
desktop software. (See Fig. 7) 

 

 

Fig. 7 Smartpen desktop program 
 
One of sharing methods is to export the digital copy of notes 

to PDF format. The PDF control toolbar is located at the 
bottom of each page in the PDF file. This toolbar controls 
playback of recorded handwriting and audio. (See Fig. 8) 

There are two ways of search and pick playback of the 
recording: the slider in the toolbar and ‘clicking’. Users can 
search and play any position in each page by moving the slider 
in the toolbar or ‘click’ on the page at which they want to 
watch. One downside of the produced PDF file is that this PDF 
file cannot be merged with a regular PDF file unless losing the 
video and the voice.  

VI. CONCLUSION 
It is widely recognized that visualization and animation of 

lecture contents give better chance students to understand the 
course content. Teaching materials with video and audio 
recordings have become the most valuable teaching modules 
especially for online and distance learning. Many technologies 
have   been   developed   to   help   producing   such   teaching  
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Fig. 8 Playing mode of smartpen note (pdf) 

 
materials. Thus, while instructors are urged to use these visual 
aids in their teaching, they are also encouraged to produce 
such material by themselves. 

However, producing such teaching materials is not an easy 
task for instructors. There are needs to find easy way to 
practice making their own teaching modules. This article 
provides a couple of examples of producing PDFs with visual 
contents so that instructors may use them as supporting 
materials for teaching. It is hoped that easier methods and 
technology would be developed which come with shorter 
learning curve, and they would benefit instructors who are 
novice to such methods. It is also hoped that the suggested 
methods in this article are not to be taken as ultimate solutions. 
Rather, it provides a starting point that instructors can use 
them as a springboard for developing their technology skills 
for producing better teaching modules.  
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